Murga-Projects Forums

Full Version: readDirectory in 0.6.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Did readDirectory disappear in 0.6.0?
Didn't that go away .5.5?
lfs is the way to go.

Code:
for file in lfs.dir("your/path/here") do
print(file)
end


I thought I had been referring to your scripts for help remembering how to do that.

iGame3D Wrote:
Didn't that go away .5.5?
lfs is the way to go.

Code:
for file in lfs.dir("your/path/here") do
print(file)
end


I thought I had been referring to your scripts for help remembering how to do that.


Thanks. I had skipped many of the releases because x86_64 was not supported. I figured I'd give the latest a try, although I'm currently on just a 32 bit machine.

oops, see what happens when I post as soon as I wake up, I mistook you for mikshaw. I thought it odd he'd ask that question. :-)

dcharno Wrote:
Thanks. I had skipped many of the releases because x86_64 was not supported. I figured I'd give the latest a try, although I'm currently on just a 32 bit machine.


No luck running on 64-bit linux. Darn ...

Quote:
No luck running on 64-bit linux.

I can't say how well it works, but have you tried compiling the source?

Quote:
I mistook you for mikshaw.

=opppp
Ain't nothing compared to some of the stupid mistakes I've made prior to coffee, or long after I shoulda been sleeping =o)

dcharno Wrote:

dcharno Wrote:
Thanks.  I had skipped many of the releases because x86_64 was not supported.  I figured I'd give the latest a try, although I'm currently on just a 32 bit machine.


No luck running on 64-bit linux. Darn ...


It runs fine for me on Mephis 64Bit ... As soon as my family leaves (this weekend), I am going to take a look at the code and try to make it 64Bit safe.

Right now it doesn't compile natively on 64Bit.

Cheers
JohnM

JohnMurga Wrote:
It runs fine for me on Mephis 64Bit ... As soon as my family leaves (this weekend), I am going to take a look at the code and try to make it 64Bit safe.

Right now it doesn't compile natively on 64Bit.


Hmmm. It complained loading libsqlite. I'll have to look at it again later tonight.

Quote:
It complained loading libsqlite.

Without seeing the error message I can only guess, but it sounds like you might just need to install or upgrade sqlite.

mikshaw Wrote:

Quote:
It complained loading libsqlite.

Without seeing the error message I can only guess, but it sounds like you might just need to install or upgrade sqlite.


Its looking for a 32-bit version, but the installed version is 64-bit.

Reference URL's