Murga-Projects Forums

Full Version: murgaua - distro compatibility
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I only thought of this thread *after* installing sqlite on Vector (5.1). Apart from that, the standard release seems to work fine in that particular distro. I have none others to test other than some from several years ago.

Some people would say that compatibility between distros is not important, but not so for the software developer.
Personally I don't think it will ever be possible without a dramatic change to distro development for a single Linux binary (other than the simplest apps) that "just works" for all the most popular distros.

On the other side of the coin, I've been plenty annoyed at some software developers who after years of creating a stable product useable on a given distro will make a minor change that makes the app completely useless. There are developers who put much too much value on the very latest libraries, forcing users into constant upgrading of things that aren't broken.

That's not to say I can even begin to understand the nuts and bolts of an operating system's code. It just seems to me that for such a solid and ever-improving OS, there sure are some illogical problems with it.
OK, reporting success!

Removed libsqlite3 and libstdc++5 from Debian Etch which I had added and new version of murgaLua runs OK. My prog had some problems with fonts but that's my problem (I imagine - it's only Debian which has shown this up).

Removed sqlite3 from Slackware 12 which I had added and new murgaLua works fine. My prog runs OK.

Also works on Mepis 7, Mandriva 2008, PCLinusOS 2007, Suse 10.3, Ubuntu 7.04, Ubuntu 7.10, Puppy 3.01 and Puppy 4 alpha6.

Brilliant John, Thanks.

Terry
I tried the distro compatibility version referenced above (02-02-2008) on a Red Hat system that didn't have libstdc++.so.5. It worked fine.

Is there a more recent distro compatibility version available?
0.6.4 contains one ;-)
I tried the latest (I think) build of murgaLua on a Linux (CentOS). Had trouble with sqlite3 which wasn't there at all. I got that installed. Then had problem with libstdc++.so.5. I scrounged up one of those. Then ran into problem with libfontconfig.so.1. I have no idea what that is.

Then I remembered this thread and installed the compatibility version posted above
http://www.murga-projects.com/murgaLua/murgaLua
and that seems to work ok and says version 0.6.0.

Will the latest release have a compatibility version at some point? Where can I download the latest compatibility version?
-------------------------------------
Ok. Answered my own question.
/snapshot/bin/Linux/otherBuilds/non-Xft/murgaLua_full
is the ticket.

Hope this might be a helpful reminder to someone who has a failing memory like me.
Pages: 1 2
Reference URL's