Murga-Projects Forums

Full Version: Adding a Package
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Quote:
error loading module 'mysql' from file './mysql.so':
./mysql.so: undefined symbol: lua_pushnil

Did you link it explicitly against liblua? You can also try to preload the lua library.

But I guess it would be a better idea to use a maintained binding like LuaSQL

Juergen

mysql.so is part of the luasql package. I got the binary from the precompiled LuaAIO package. It works ok if I use the lua command interpreter that comes with LuaAIO, but doesn't work with 0.6.8 murgaLua.
Did you copy the lua51.dll (or whatever it is named) from luaAIO into the directory where your luamysql.dll resides?

Juergen
I ran murgaLua from a directory containing all the LuaAIO .so files including lua.so and liblua5.1.so

When I run murgaLua and require'something'

I get a message like

./mysql.so: undefined symbol: lua_pushnil
./rexlib.so: undefined symbol: lua_getfield
./lxp.so: undefined symbol: lua_newuserdata
Pages: 1 2
Reference URL's