Murga-Projects Forums

Full Version: Build process
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
As I've still got some time to spare, I was looking into debugging the Red Color Channel problem (see here).
I installed all required packages as in packages.txt, but I did not succeed in building the whole thing. It stopped with this complaint:

Code:
In file included from bind-fltk-ext.cxx:24:
fltk.cxx:26: fatal error: FL/Fl.h: No such file or directory
compilation terminated.
make[2]: *** [bind-fltk-ext.o] Error 1
make[2]: Leaving directory `/home/jpjacobs/sandbox/murgalua/murgaLua/src'
make[1]: *** [linuxStatic] Error 2
make[1]: Leaving directory `/home/jpjacobs/sandbox/murgalua/murgaLua/src'
make: *** [linuxStatic] Error 2


I checked and /usr/include/FL/Fl.h exists and this does not give problems with the other fltk examples (in C++) I tried to compile.

So what's there more to do to compile the code?

PS: Having the code in something like github would be significantly easier to send in patches etc.

What does fltk-config tell you? Maybe it's pointing to /usr/local/include or something like that.
Well, I don't have a clue what fltk-config option I'm looking for... just that it works nicely with the helloworld example that comes with it (through fltk-config even).

jpjacobs Wrote:
Well, I don't have a clue what fltk-config option I'm looking for... just that it works nicely with the helloworld example that comes with it (through fltk-config even).


If you are using my batch files they expect things to be installed to /usr/local and not /usr ...

I think that is your problem ...

This line in the script "export INSTALL_TOP=/usr/local"

I tried replacing all occurances of /usr/local by /usr, to no avail ... Still getting the same error.
Any other ideas?
Thanks, JP
I'm no compiling wizard, but maybe add -I/usr/include to CXXFLAGS in Makefile
Good idea, but still the same old error...
Okay then...

What about ln -s /usr/include/FL /usr/local/include/FL
I don't know if this will help, considering fltk-config is probably still pointing to /usr/include

You might end up having to reinstall Fltk with /usr/local prefix

jpjacobs Wrote:
I tried replacing all occurances of /usr/local by /usr, to no avail ... Still getting the same error.
Any other ideas?
Thanks, JP


Sorry, been away ...

Where did you replace this ?

In:

* tools/build/build-LinuxAll.sh
* tools/build/build-LinuxXft.sh
* src/Makefile
* tools/build/patches/cross/lua_Make-top.patch

I think that's all, but still a no go.
Reference URL's