Murga-Projects Forums
io.popen not supported? - Printable Version

+- Murga-Projects Forums (http://www.murga-projects.com/forum)
+-- Forum: Project Forums (/forumdisplay.php?fid=1)
+--- Forum: MurgaLua - General (/forumdisplay.php?fid=2)
+--- Thread: io.popen not supported? (/showthread.php?tid=27)


io.popen not supported? - iGame3D - 05-27-2007 08:31 AM

I have had a few issues with some of lua's functions from within lua and murgaLua.
For instance io.popen complains about not being supported.

Code:
> io.popen("fluid")
stdin:1: 'popen' not supported
stack traceback:
        [C]: in function 'popen'
        stdin:1: in main chunk
        [C]: ?


In iGame3D it works but I don't know what we did different as far as lua/murgaLua goes.

Any clues?


RE: io.popen not supported? - mikshaw - 05-27-2007 03:03 PM

popen support was added in version 0.4.1
That was one of the things I had been looking forward to myself.


RE: io.popen not supported? - iGame3D - 05-27-2007 09:06 PM

I did the build, I must not have done something right.
Back to the terminal...


RE: io.popen not supported? - mikshaw - 05-27-2007 09:49 PM

It apparently does have something to do with how it's built, although I can only point you to another thread and hope you understand it, because I didn't =o)
http://www.murga-projects.com/forum/showthread.php?tid=10


RE: io.popen not supported? - iGame3D - 05-27-2007 10:13 PM

Yeah my build is no go for popen on mac os intel.
Tobi has a Universal binary somewhere that probably solves this problem, I know he did some tricks to the make file. Hope we can get this squared away.


RE: io.popen not supported? - JohnMurga - 05-30-2007 06:11 AM

Sorry, a few things came up with my personal life and I have been traveling lately.

Yes, this problem is due to the way LUA is built.

The popen test is pure LUA, so rebuild LUA with "make bsd; make install" and you
should be able to use popen ... I thought the macOs binary worked :-(

Anyway, then you'll have to re-build murgaLua.

Cheers
JohnM


RE: io.popen not supported? - iGame3D - 05-30-2007 05:51 PM

Ok I've rebuilt it, a few times, finally got it to work right.
murgaLua Mac OS X (BSD build) .0.4.1