News : The level of daily SPAM has reached insane proportions, all registrations are now manual. I ask you to send me an e-mail (john (at) murga (dot) org), to confirm that you want me to create an account for you.

Post Reply  Post Thread 
murgaua - distro compatibility
Author Message
Junior Member

Posts: 11
Group: Registered
Joined: Dec 2007
Status: Offline
Reputation: 0
Post: #1
murgaua - distro compatibility

Hi there,
I started looking at murgaLua around December with a view to learning to program in a windows type environment. I'd had little experience of programming in the past other than in Basic on a BBC B years ago and on my Psion Revo. I set about making a little banking program using a simple database to record transactions both debit and credit and which would display a month at a time in a window on my PC.
This went very well and after 'stealing' bits of code from various places - mostly John Murga's sqlTool.lua prog and bits from Mikshaw's progs, I had a working program which did just what I wanted. Brilliant!!
I did this using Puppy Linux 3.01 - a super little distro - on a laptop, and was very happy. So, I wondered about backing up my efforts on my main computer which uses Ubuntu 6.06 LTS.
I copied the murgaLua run-time to /usr/bin, as on my laptop, and the Bank.lua prog and the database.db file into my home directory. I checked the permissions on all the files and tried to run Bank.lua. It crashed!
I transfered sqlTool.lua and ran that and it told me my database.db file was an "unsupported file format".
I re-ran Bank.lua in Ubuntu 6.06 and made a new database file - test.db - and of course this was OK. Strangely, when I transfered test.db to my original Puppy Linux, it also worked fine!
This got me to thinking, how would it be with other distros, so, I dug out an old laptop which had several recent distros on it and did exactly the same for each one.
The result was that Ubuntu 7.04, Ubuntu 7.10, Suse 10.3, PCLinuxOS 2007, Mepis 7, and Mandriva 2008 all worked perfectly, my original database.db file opening happily on each one.
The two distros that failed were Debian Etch and Slackware 12. Both these wouldn't run the basic murgaLua, coming up with the same error :- "error while loading shared open shared object file:no such file or directory".
I imagine that I must have done something wrong, but what?
I haven't tried it with Microsoft Windows, about the only thing I use that for is to run Repton 1/2/3 and Xor games. I guess that dates me.

Anyone have any ideas?

01-28-2008 12:26 AM
Find all posts by this user Quote this message in a reply
Post Reply  Post Thread 

Messages In This Thread
murgaua - distro compatibility - TerryW - 01-28-2008 12:26 AM
RE: murgaua - distro compatibility - asafp - 03-19-2008, 11:21 AM
RE: murgaua - distro compatibility - asafp - 07-10-2009, 08:44 AM

View a Printable Version
Send this Thread to a Friend
Subscribe to this Thread | Add Thread to Favorites

Forum Jump: