News : The level of daily SPAM has reached insane proportions, all registrations are now manual. I ask you to send me an e-mail (john (at) murga (dot) org), to confirm that you want me to create an account for you.


Post Reply  Post Thread 
Pages (2): « First < Previous 1 [2] Last »
"murgaLua -e string" in Windows and Mac
Author Message
mikshaw
Senior Member
****


Posts: 522
Group: Registered
Joined: Apr 2007
Status: Offline
Reputation: 5
Post: #11
RE: "murgaLua -e string" in Windows and Mac

Still haven't gotten back on a Windows machine to find a definite solution. I may just release the next widgets_demo beta as-is and hope someone else can fix it if it's broken in Windows =o)

02-28-2008 12:06 AM
Find all posts by this user Quote this message in a reply
JohnMurga
Administrator
*******


Posts: 381
Group: Administrators
Joined: Apr 2007
Status: Offline
Reputation: 2
Post: #12
RE: "murgaLua -e string" in Windows and Mac

mikshaw Wrote:
Still haven't gotten back on a Windows machine to find a definite solution. I may just release the next widgets_demo beta as-is and hope someone else can fix it if it's broken in Windows =o)

I'll volunteer to do that :-)

Cheers
JohnM

02-28-2008 01:17 AM
Visit this user's website Find all posts by this user Quote this message in a reply
iGame3D
Moderator
***


Posts: 231
Group: Moderators
Joined: Apr 2007
Status: Offline
Reputation: 0
Post: #13
RE: "murgaLua -e string" in Windows and Mac

While we are on the topic, whats the " -e " for anyway.
Is there somewhere that explains those arguments?

02-28-2008 07:28 AM
Visit this user's website Find all posts by this user Quote this message in a reply
mikshaw
Senior Member
****


Posts: 522
Group: Registered
Joined: Apr 2007
Status: Offline
Reputation: 5
Post: #14
RE: "murgaLua -e string" in Windows and Mac

It's a standard Lua commandline option, documented in section 6 of the Lua manual.

Quote:
-e stat: executes string stat

So for example, the following command would set scriptname.lua to use the plastic scheme even if Fl:scheme(NULL) is not in the script:

Code:
murgaLua -e "Fl:scheme('plastic')" scriptname.lua


In the new widgets_demo layout I'm using this to set the images variable so individual scripts can find the images. The scripts themselves cannot find this directory because they are run from temp files.

02-28-2008 08:16 AM
Find all posts by this user Quote this message in a reply
Pages (2): « First < Previous 1 [2] Last »
Post Reply  Post Thread 

View a Printable Version
Send this Thread to a Friend
Subscribe to this Thread | Add Thread to Favorites

Forum Jump: